Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
When trying to add an Item within a Ticket, the system suggests multiple products, and upon pressing enter, the system selects the wrong item.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Service WC.
- Open the Tickets view.
- Choose a ticket from the list.
- Switch to the Items tab within the selected ticket.
- Click the "Add" button to add a new item.
- In the "Product" field, type "XXX" to search for a product.
- Observe that the dropdown menu shows multiple products.
- Press enter.
- Note that the system selects the incorrect product.
Cause
For this scenario, we are going to use two products as example.
Product A
- Name: NameA
- ID: XXX
Product B
- Name: XXXNameFromB
- ID: YYY
Now, if you search for "XXX" (which is the ID of Product A) and press enter, you will notice that Product B is selected instead of Product A.
This happens because the system prioritizes searching by the product Name before it looks for the product ID. Since Product B name contains "XXX", it gets chosen first.
Please refer to the following screenshot for a clearer understanding of the issue:
Resolution
To avoid this scenario, Product B name should be updated to remove any reference to the ID "XXX" from Product A. This change ensures that "XXX" is associated only with Product A ID, eliminating any confusion with product names. This is the standard system behavior.
Keywords
Type-ahead, Dropdown, Items, Products, ID, Name, Tickets, Wrong Product, Incorrect Selection , KBA , LOD-CRM-SRP , Service Request Processing , Problem