Symptom
Users are not able to create a custom query for Visits or Sales Quotes section inside Opportunity. After the attempt to create a personalized query, users still see default query only.
Environment
SAP Cloud for Customer
Reproducing the Issue
For Visits:
- Go to Sales > Opportunities.
- Open one.
- Go to Activities tab.
- Now go to Menu > Start Personalization.
- In Visits section, click on more > Add Predecessor.
- Click help button.
- Click advanced search icon.
- On any field, for example Subject, enter for example, *test*.
- Go.
- Click on 'Save Query as'.
- Change the name and mark "set as default".
- End personalization.
- Repeat steps 5 and 6.
- See the query is still the same and not the custom one just created.
- Instead of showing few results with "test" value, it is showing all results.
For Sales Quote:
- Go to Sales > Opportunities.
- Open one.
- Go to Sales Documents tab.
- Now go to Menu > Start Personalization.
- In Sales Quotes section, click on more > Add Successor.
- Click help button.
- Click advanced search icon.
- On any field as Account, enter for example, *test*.
- Go.
- Click on 'Save Query as'.
- Change the name and mark "set as default".
- End personalization.
- Repeat steps 5 and 6.
- See the query is still the same and not the custom one just created.
- Instead of showing few results with "test" value, it is showing all results.
Cause
Inside Opportunities, the OVS COD_Visit_SOVS for Visits is configured to display only the "All" query option. The same behavior applies for OVS COD_Quote_SOVS for Sales Quotes.
Resolution
This is the expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
/BYD_COD/SalesOnDemand/Visit/VisitExecution/COD_Visit_SOVS.OVS.uicomponent, anchor missing, UI, AdvancedListPane, DefaultSetMapping, personalised, standard, , KBA , LOD-CRM-OPP , Opportunity Management , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-ACT-VST , Visit Planning , Problem