Symptom
When creating a new user with the SCIM api, the UserID property cannot be set. Instead, it is set to the value of the username property minus any punctuation and with anything after a @ symbol removed.
e.g.
If you do a POST call to the URL {{ _.Tenant_Url }}/api/v1/scim/Users/ with a body
{
"schemas": ["urn:ietf:params:scim:schemas:core:2.0:User", "urn:ietf:params:scim:schemas:extension:enterprise:2.0:User", "urn:ietf:params:scim:schemas:extension:sap:user-custom-parameters:1.0"],
"userName": "test1.test2@sap.com",
"id": "test123",
"preferredLanguage": "en",
"name": {
"givenName": "testa1",
"familyName": "testa2"
},
"displayName": "testa1 testa2",
"active": true,
"emails": [{
"value": "test1.test2@sap.com",
"type": "work",
"primary": true
}
],
"roles": [],
"groups": [],
"urn:ietf:params:scim:schemas:extension:sap:user-custom-parameters:1.0": {
"dataAccessLanguage": "de",
"dateFormatting": "dd.MM.yyyy",
"timeFormatting": "H:mm:ss",
"numberFormatting": "1.234,56",
"systemNotificationsEmailOptIn": false,
"marketingEmailOptIn": false
}
}
The resulting UserID with be "test1test2"
Note: With the SCIM api, the userName property must match the SAML attribute to be used within SAC. So for this example, the SAC tenant is configured to use Email as the SAML attribute.
Environment
- SAP Analytics Cloud 2025.1.1
Cause
This behavior is by design. Also, the UserID property cannot be modified after creation.
Resolution
If you want to specify a custom UserID property, you must use the SCIM2 api. With the SCIM2 api, you can specify a custom UserID property with the userName attribute, and the SAML attribute is passed in as part of the idpUserName property.
e.g.
Do a POST call to {{ _.Tenant_Url }}/api/v1/scim2/Users/ with the body
{
"schemas": [
"urn:sap:params:scim:schemas:extension:sac:2.0:user-custom-parameters",
"urn:ietf:params:scim:schemas:core:2.0:User"
],
"userName": "MyCustomID",
"name": {
"familyName": "testa1",
"givenName": "testa2",
"formatted": "testa1 testa2"
},
"displayName": "testa1 testa1",
"active": true,
"emails": [
{
"value": "test1.test2@sap.com",
"type": "work",
"primary": true
}
],
"roles": [
{
"value": "PROFILE:sap.epm:BI_Admin",
"display": "BI_Admin",
"primary": true
}
],
"urn:sap:params:scim:schemas:extension:sac:2.0:user-custom-parameters": {
"idpUserId": "test1.test2@sap.com",
"isConcurrent": false,
"marketingEmailOptIn": true
}
}
The resulting UserID with be "MyCustomID"
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using SAP for Me, Google or Bing:
- https://me.sap.com/servicessupport/search#?q=SAP%20Analytics%20Cloud%20OR%20SAC&tab=All
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SCIM, API, SCIM2, User, UserID, REST, RESTFul , KBA , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-LS , Licensing and Full User Equivalent , Problem