Symptom
Warranty details are missing from the Warranty section in the Service Order.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Select the Service Order Processing view.
- From the drop-down, select All Orders.
- Search for Service Order ABC (Where ABC represents the Service Order ID).
- Click in Edit.
- Under Affected Product the Warranty Reference Date is visible.
- Click on View All and go to the Account and Affected Product sub tab.
- Under the Warranty section, the warranty details do not appear as expected.
Cause
In the Service Order ABC, the Reported On date is required, as this will determine when the customer requested the service to be performed. This date is important for further processing as it is copied to the spare parts and is used to check their availability.
For the Registered Product DEF (Where DEF represents the Registered Product ID) used in the Service Order ABC, the Warranty Reference date is defaulted from the Registered Product. When you give the Warranty GHI (where GHI represents the Warranty ID), which has a duration of 12 months, today's date, the Reported On date which is on e.g 13.08.2024 surpasses the Warranty end date e.g 13.06.2014. Therefore, the Warranty GHI does not appear in the Service Order because the coverage does not exist for the Reported On date.
In case you change the Reported On date within the Warranty Start Date and Warranty End Date, the system will be able to determine the Warranty as expected.
Please refer to the below example:
- Go to Service Orders work center
- Select Service Order Processing view
- In the drop-down menu, select All Orders
- Search for Service Order ID ABC
- Click in Edit and View All
- Under General tab, navigate through the Main Information subtab
- Under Order Description, Reported On Date is set as e.g 13.08.2024
- Go to Account and Affected Product subtab
- Under Affected Products section, double click in the Registered Product DEF
- Click in View All
- Under Registered Product section, we can see the Warranty Reference Date is set as e.g. 13.06.2013
- Under Warranty Assignment section we have the following:
- Warranty: 12 months warranty
- Coverage: Goodwill 100%
- Duration/UoM: 12 Month(s)
- Warranty Start Date: 13.06.2013
- Warranty End Date: 13.06.2014
Resolution
In order to resolve the issue, please refer to the following options:
- Option 1: Change Warranty Reference date of the Registered Product if you want to use the same Warranty GHI.
- Option 2: Use a new Warranty that has a duration which covers the present date.
In case you change the Reported On date within the Warranty Start Date and Warranty End Date, the system will be able to determine the Warranty as expected.
Keywords
Not correct, not expected, incorrect, does not exist , KBA , SRD-CRM-INV , Customer Invoicing , Problem