Symptom
When Releasing a Customer Return using the option Without Credit Memo, the error "Return cannot be Released because gross amount is not zero" is raised and the Return is not Released.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Open the Returns view.
- Find and Open the Customer Return ABC (Where ABC Represents the ID of the Customer Return).
- Click on Release - Without Credit Memo
The system returns the error "Return cannot be Released because gross amount is not zero" and the Return is not Released.
Cause
This error happens when the List Price is is different from the Quality Loss Fee, so the Net Value is not 0, which is why an error occurs when Releasing the Return without a Credit Memo.
Resolution
For Returns with the Inbound Status "Finished" and the Credit Memo Status "Not Started", you have two options to complete the Returns:
First, you can add a Quality Loss Fee equivalent to the Net Value of the Items listed in the Items tab for each item, and then release it without a Credit Memo.
Alternatively, you can release the Return with a Credit Memo and subsequently invoice the Return Invoice Request.
Keywords
Customer Return, Credit Memo, Quality Loss Fee, Gross, Net, Amount, Zero, 0, Release, Unable, Impossible, Cannot, Return Invoice Request , KBA , AP-CRP-CR , Customer Return , How To