Symptom
User is being assigned roles that are supposed to be for managers only even though in the UDF, this user doesn't have any direct reports.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login to the instance
- Go to Role-Based Permissions Troubleshooting Tool page
- Type the affected user's name in "Access User 1" field and click search
- At the search bar for permissions and roles below, search "API"
- You will see the permission "Employee Central API" assigned to affected user through 3 different roles meant for manager.
- Click "Base - All Manager's role" as it has the simplest filter
- Go to Assignments tab and you will see that this Role is meant to be for "Managers in the following groups" (meaning it should only include managers)
- Go to Employee Exports and download the file
- Search for affected user and you will see that this user is not in the Manager column for any users
*Note: This is only one way to check for affected user's manager's permission role and depends on your RBP structure. But basically, you just need to prove that user is not a manager but shows in permission roles for managers in the RBP Troubleshooting Tool
Cause
Affected user has no internal direct report but has external direct report that can't be seen in User Data File or in Org chart.
Resolution
Create and submit a support case using the LOD-SF-PLT-RBP component to seek for help to resolve the issue as this will need running a script to identify all external direct reports for the affected user.
After the external direct reports have been identified, you need to permanently purged the external direct reports to finally remove the affected user from manager's people pool.
***FOR SUPPORT ENGINEERS: See internal memo***
See Also
Keywords
manager, RBP, incorrect, roles, security, external, direct reports, not manager, RBP error, UDF , KBA , LOD-SF-PLT-RBP , Role Based Permissions , How To