SAP Knowledge Base Article - Public

3574245 - Alerts are not triggering for onboarding users

Symptom

Alerts are being created for onboarding user who is not yet hired in EC, but it is not triggering.

Environment

SAP SuccessFactors - Employee Central

Reproducing the Issue

  1. Hire an employee through Onboarding.
  2. The employee will be passed to Manage pending hire page.
  3. Based on the rule configuration, alert got created and it is visible under " Manage Alerts and Notifications ".

Cause

The EC Alert and Notification Job contains two parts, create alert and process alert:

When the job creates alert the subject user's status does not impact the logic to create alert as long as the EC data matches the create alert business rule. So, it does not matter if it's for an onboardee (not yet hired in EC) or a new hire added through Add New Employee wizard, you can search and view the alert in Manage Pending Alerts and Notifications page. However, viewing it here does not mean that the alert email notification will trigger, since this depends on the processing part of the job.

When the Job processes alert it will pick up the alerts according to the effective date that are set in the business rule, and trigger alerts for those subject users whose:

  • Status is T or t (i.e., Active user).
  • Status is F but have a future employment information change (i.e., Inactive user).

However, for onboarding users (either not hired in EC, or hired in EC with future hire date), the criteria for the alert getting sent depends on the subject user status before the alert processing.

For an Onboardee hired in EC with future hire date, the status is still "e" which is one day prior to the date and the status changes to Active once the "ConvertExternalUserOnStartDateJob" runs on the hire date, and therefore no alert email notification is triggered.

Resolution

It is an expected behavior. The generated alert appears on Manage Pending Alert and Notifications page, however it's still pending and will be processed based on effective date and employee status.

Note: If the alert is set up to trigger 1 day after the hire date, the alert would trigger as the conversion job would have run and the status would change to Active.

See Also

2315275 - Employee Central - Workflows & Alerts

Keywords

alerts, email notification, onboardee, inactive users, Manage Alerts and Notification, external user, effective date, employee status, EC Alerts and Notifications, Scheduled Job Manager, Manage Pending Hire, MPH, ONB, ConvertExternalUserOnStartDateJob, INC3305031 , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC-INT-ONB , Onboarding 1.0 to EC Integration , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions