Symptom
An extension field was created in a Customer Demand, but after its creation, the field remains blank and non-editable.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Sales Orders view.
- Open the relevant Sales Order.
- Go to the Document Flow tab.
- Select Extended View.
- Click on the corresponding Customer Demand ID.
- Click on View All.
- In the General tab, locate the created extension field.
- Note that the field cannot be updated.
Cause
The described behavior is expected. An extension field can be added with default information, but this information will only be displayed after the sales order is released. Additionally, the screen in question is view-only, meaning that no edits can be made to the field.
Resolution
Expected system behavior
Keywords
KUT, Customer Demand, Updatable, Missing , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , How To
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public