Symptom
While attempting to edit the Position via the Position Org Chart, the "Cancel" button is not responding in the following scenarios (with the pre-requisite that a custom Position UI is assigned as the default screen):
Scenario 1: There is an onChange rule assigned on the Effective Start Date field in the Position object to throw up an error message if a back-dated start date is entered.
Scenario 2: In the Effective Start Date field, instead of editing the position with today's date which is shown by default, enter the same date as that of the existing (i.e., latest) position record.
Environment
SAP SuccessFactors Employee Central - Position Org Chart UI
Reproducing the Issue
Scenario 1:
- Navigate to the Position Org Chart UI.
- Select a position and choose 'Show Details' > 'Edit'.
- The system shows today's date by default in the Effective Start Date field.
- Select a backdated start date, an error message appears.
- Click 'OK', it redirects to the position edit page again.
- Click 'Cancel', the screen does not respond.
Scenario 2:
- Navigate to Position Org Chart UI
- Select a position and choose 'Show Details' > 'Edit'.
- The system shows today's date by default in the Effective Start Date field.
- Instead, enter the date which is already present in the existing Position record. For example, if the Position has the latest record effective 1/1/1900, enter the same in the effective start date.
- Click "Proceed" > Click "Cancel" > Click "Don't Save" > The screen does not respond.
Cause
This issue is occurring due to a defect.
Resolution
Engineering team has created a code correction and is planning to fix this issue in the upcoming 1H 2025 release.
Workaround:
Edit positions via Manage Data page.
Keywords
INC11113774, CS20250009284452, CS20250009230095, MDF-89791, SAP SuccessFactors Employee Central, Position Org Chart, Edit, Cancel button, Backdated, onChange, freeze , KBA , LOD-SF-EC-POS-ORG , Position Org Chart UI & Manage Positions , Known Error