SAP Knowledge Base Article - Public

3575360 - Custom Approval Process Error Action Disabled

Symptom

User may receive an error called " Action POST not possible; action is disabled" during clicking on Submit action.

Environment

SAP Business ByDesign

SAP Cloud for Customer 

Reproducing the Issue

  1. Go to Custom developed Work Center
  2. Check the custom view, where the instances are stored
  3. search for the ID
  4. View and click on Submit
  5. Error appears

 

Cause

The Submit button throws the action disabled error when the approval status of the instance is not set.

Resolution

Partner to cross check the implementation and see how these instances are created and default the approval status has to be set, by binding the UI fields defined in the action or by their logic. As these buttons will remain disabled as long as the approval status is not set for those fields. 

See Also

You may refer to similar KBA as well  https://itsm.services.sap/kb?id=kb_article_view&sysparm_article=KB0655573 as well.

Keywords

Approval Process; Instance not set; Action is disabled; , KBA , AP-RC-BDS-BTM , ByDesign Studio Business Task Management , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications all versions