SAP Knowledge Base Article - Public

3575450 - Candidate emails are being sent from 'system@successfactors.com' instead of the custom Return Address - Recruiting Management

Symptom

Email sender remains as 'system@successfactors.com' after setting up 'Return address for system-generated emails to candidates'.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Configure a custom email address for 'Return address for system-generated emails to candidates' in Manage Recruiting Settings.
  2. Trigger a password reset email for an external candidate account.
  3. Notice that the email sender remains as 'system@successfactors.com'

Cause

A custom email domain is used but it is not verified in 'Manage Email Notifications'. In this case, the system will still send emails from the system email address. This is an expected behavior since 2H 2024 release.

Resolution

1. Add and verify the custom email domain in 'Manage Email Notifications'. For further information, see the following KBA:

2. Ensure that the IT/mail administrator has setup SPF or DKIM to authenticate SuccessFactors as a sender for the custom email domain. For further information, see the following KBAs:

See Also

Keywords

RCM, Sender, Change, Recruiting, Email, Notification, custom domain, Manage Email Notifications, SPF, DKIM, authenticate, Configure, Return address for system-generated emails to candidates , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions