Symptom
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When creating an appointment from a ticket screen, you will see that visits are also getting automatically created with the same appointment ID.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service Work Center.
- Go to the Tickets view.
- Open any ticket ABC (where ABC is a ticket Id).
- Go to Appointment facet and create an appointment.
- You will see an appointment LMN (where LMN is appointment Id).
- Now, go to Visits facet.
Here, You will see that visits are being automatically created as well with the same ID as LMN.
Cause
When creating an appointment, it was previously displayed in both the Appointments and Visit facets. Now with 2502 upgrade, the old Visits facet has been deprecated.
Resolution
You need to hide the old deprecated visit facet and make the new visit facet visible via adaptation, follow the steps below:
- Go to Service work center.
- Go to Tickets view.
- Click the User profile.
- Click on Start Adaptation.
- Navigate to UI View Area.
4. Go to "Views"
5. Select the object from the list. In this case, "Visits"
6. Set the visibility as Hide for "Visits (Deprecated)"
7. Set the visibility as unhide for "Visits"
8. End Adaptation Mode
Keywords
Tickets, Visits, ID, Appointment, Deprecated , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
Attachments
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| Picture 1.png |
| Picture 2.png |
| Deprecated.png |
| Hide.png |
| Ticket.png |
| Adaptation Mode.png |
SAP Knowledge Base Article - Public