SAP Knowledge Base Article - Public

3575463 - Visit Are Incorrectly Created Automatically When Appointment Is Created.

Symptom

Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

When creating an appointment from a ticket screen, you will see that visits are also getting automatically created with the same appointment ID.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service Work Center.
  2. Go to the Tickets view.
  3. Open any ticket ABC (where ABC is a ticket Id).
  4. Go to Appointment facet and create an appointment.
  5. You will see an appointment LMN (where LMN is appointment Id).
  6. Now, go to Visits facet.

Here, You will see that visits are being automatically created as well with the same ID as LMN.

Cause

When creating an appointment, it was previously displayed in both the Appointments and Visit facets. Now with 2502 upgrade, the old Visits facet has been deprecated.

Resolution

You need to hide the old deprecated visit facet and make the new visit facet visible via adaptation, follow the steps below:

  1. Go to Service work center.
  2. Go to Tickets view.
  3. Click the User profile.
  4. Click on Start Adaptation.
  5. Navigate to UI View Area.

4. Go to "Views"

5. Select the object from the list. In this case, "Visits"

6. Set the visibility as Hide for "Visits (Deprecated)"

7. Set the visibility as unhide for "Visits"

8. End Adaptation Mode

Keywords

Tickets, Visits, ID, Appointment, Deprecated , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions

Attachments

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