Symptom
- Users are able to access the adaptation mode in SAP Sales/Service Cloud, even though the extensibility service is not added.
- This issue occurs when a specific role is assigned to the users that should only give them access to import/export data admin tool.
- The adaptation mode becomes visible when the user clicks on the user menu button.
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2
- SAP Sales Cloud Version 2
Reproducing the Issue
- Login to SAP Sales/Service Cloud with the user credentials.
- Click on the user menu button.
- Notice that the adaptation mode is visible, even though the extensibility service is not added to the user's roles.
Cause
Adaptation Mode would appear to all admins and is not dependent on service assignment.
Resolution
- This is the expected behavior.
- Adaptation Mode would appear to all admins and is not dependent on service assignment.
- If an admin attempts to make any changes on the User Interface (UI) without the extensibility service assigned, the changes will not be saved and an error will be thrown on the UI.
See Also
Keywords
SAP Sales/Service Cloud, non-admin users, adaptation mode, extensibility service, role assignment. , KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public