Symptom
An error occurs when try to replicate checklist from FSM to C4C in the form of "Checklist Template is mandatory for Checklist Instance ABC" (ABC represents for the instance ID)
Environment
SAP Cloud for Customer
Reproducing the Issue
- Replicate checklist from FSM to C4C.
- Check Web service monitoring in C4C tenant.
- Observe the error "Checklist Template is mandatory for Checklist Instance ABC"
Cause
This issue is occurring primarily as the corresponding template confirmation ( to FSM per example ) has not been successful. If the template is successfully replicated to C4C, along with a successful confirmation to FSM, then this issue will not occur.
Resolution
Please check your Iflow and Integration logs between C4C and FSM to validate the details on why FSM is not confirming the request.
The following FSM Help Document might also be useful:
https://help.sap.com/docs/SAP_FIELD_SERVICE_MANAGEMENT/fsm_admin/create-checklist-instance.html
Keywords
FSM, C4C, Checklist Instance, Application Error, Replication, Template, Iflow. , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , Problem