Symptom
You are replication business partners from SAP S4HANA to SAP Sales & Service Cloud V2 and the message in V2 fails with error "employeeInformationIsMissing"
Environment
SAP Sales & Service Cloud V2 Integration with SAP S4HANA
Reproducing the Issue
- Go to Settings
- Check the failed message with interface "businessPartnerS4ReplicationMessageIn "
- Navigate to the error and check the error mentioned below
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"The employeeInformation node is missing.\",\"code\":\"sap.crm.md.service.businessPartnerService.employeeMessage.employeeInformationIsMissing\"}}"
}
],
"errorDetailsAsJson": "[{\"code\":\"400\",\"message\":\"{\\\"error\\\":{\\\"message\\\":\\\"The employeeInformation node is missing.\\\",\\\"code\\\":\\\"sap.crm.md.service.businessPartnerService.employeeMessage.employeeInformationIsMissing\\\"}}\",\"details\":[],\"errorDetailsAsJson\":null}]"
}
Cause
You are sending employees using the Business Partner Interface.
Resolution
- You have to first do initial load of all employees using the dedicated idoc based interface (Basically, you have to filter the employees based on role in the DRF so that they are not sent out)
- Then you have to load the employees using the business partner interface so that HCM identification id's gets created as external id's and a business partner id mapping as well is created
Keywords
"employeeInformationIsMissing" ; "businessPartnerS4ReplicationMessageIn" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0