Symptom
During Registered Product creation, 500 Internal Server error(Dump) occurs.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Products or Installed Base Work center.
- Click on Registered Product Work center view.
- Click on the Create(+) button.
- Fill up all the mandatory fields and click on 'Save'.
Notice that dump occurs.
Cause
This happens when old Registered Product Quick Create UI is used.
Resolution
In order to resolve the issue following Scoping question needs to be enabled.
- Go to Business Configuration Work center.
- Click on Implementation Project Work center view.
- Click on Edit Project Scope for current project.
- Navigate to step 4 - 'Questions'.
- Go to Service Work Center View
- Navigate to Entitlement Management View
- Search for Registered Products and Installed Base.
- Enable the question 'You can enable the new Registered Product Quick Create that allows you to add extension fields from Installation Point business context'.
By enabling the question customer can use New Quick Create screen which allows Extension fields in Registered Product detail view.
Keywords
Registered Product, Dump, Quick Create, UI, Product, Scoping Question, Extension Field, Equipment. , KBA , LOD-LE-IBA-IPO , Installation Point , Problem
Product
SAP Cloud for Customer core applications all versions