Symptom
You are trying to generate the readiness report for opportunity scoring scenario but it is stuck in status generating report.
Environment
- SAP Cloud for Customer.
Reproducing the Issue
- Navigate to administrator work center and open the prediction services.
- Click on model setup.
- Highlight the Opportunity Scoring scenario and click on generate report.
- After allowing sometime to pass the report is still stuck in generating report.
Cause
If there is a very high volume of opportunity data in the system this can cause the report to dump. There are restrictions currently on how much data can be processed for this specific readiness report.
Resolution
If your readiness report is stuck in this status please raise a case with us in technical support under LOD-CRM-ML as it will need to be removed from the backend to allow you to train a new model. Once this is done do not try to generate the report again.
Regarding the content of the Readiness Report – as a workaround that can be retrieved from the system.
- Data Volume (Overall) – Value can be retrieved by doing a query on the Opportunity work center view.
- Data Volume (Last 12 months) – Value can be retrieved by doing a query with selection parameter (Status = Won AND Status = Lost AND Created on Last 12 months) on the Opportunity work center view.
- Win Rate - Can be calculated by calculating the percentage of opportunities won in the last 12 months. Data can be retrieved also from the Opportunity work center view by doing queries.
You can compare you results to the target numbers below:
Keywords
Opportunity, Score, Scoring, readiness, report, model, machine learning, generating, cloud for customer, data, volume, win rate, accuracy, setup, prediction services , KBA , LOD-CRM-ML , C4C Machine Learning , Problem