SAP Knowledge Base Article - Public

3576841 - Visit or Appointment Does Not Get Delivered to an Attendee Once it is Synced From C4C to Outlook

Symptom

A visit is undeliverable to an attendee when synced from C4C to Outlook, if the email of attendee consists of an apostrophe.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Create a visit and add an attendee whose email ID consists of an apostrophe " ' "
  2. Sync the visit to your outlook
  3. You get an email from outlook saying the visit it is undelivered as the email is not valid and everything before the apostrophe not considered in the email.

Cause

It is not suggested to include special characters like an "Apostrophe symbol" as the email can become undeliverable. When syncing, since the special character is not supported, it is only considering the value after this character and is failing to deliver the message as the email is not valid. Ideally, email ids should not consist of spaces, colons, semi-colons, brackets, parentheses, or other such delimiters. When creating email always stick to alphanumeric characters like periods (.), and hyphens (-).

Resolution

This is the expected behavior

Keywords

Undeliverable, apostrophe, special character, email, outlook, server side integration, sync , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , LOD-CRM-GW-OUT , Outlook , Problem

Product

SAP Cloud for Customer core applications 2502