SAP Knowledge Base Article - Public

3577748 - Rule Not Working For Relationship List

Symptom

Adaptation/PDI Rule not working for List based value where the list contains more than one record.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login to C4C
  2. Navigate to Customer -> Contacts
  3. Open any Contact and Navigate to Relationship Tab (where relationship list has more than one records)
  4. Maintain any Dependency Rule (visibilty ,default , mandataory etc) where the property of this field depends on another field .
  5. Example : Field ABC's mandatory property depends on Field XYZ being initial .
  6. Now, if u click on first line item of the relationship tab, the set rules works correctly , whereas if we navigate to second or further line items  the set rules are not working.

Cause

This is a known behavior . Rule would imply for only first line item in a list.

The reason behind such behavior is that when a Adaptation/PDI rule or logic is applied to a TI screen, it is limited to the first line of action only . We cannot extend Rule behavior to other line items in a list.

Resolution

This is an expected behavior for list type of field values.

Keywords

List Type , Relationship, Rules, Rule, List , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Known Error

Product

SAP Cloud for Customer core applications all versions