Symptom
- Truncated Bank Account Number is displayed for an Employee in the generated Outgoing File.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Payment Management work center.
- Go to the Payment Monitor view.
- Search for the relevant Payment ID.
- Open and download the respective Outbound File ID.
- It can be noticed that for a particular employee, the bank account number is truncated.
Cause
- Go to the Personnel Administration work center.
- Go to the Employees view.
- Search for the respective Employee ID.
- Choose Edit.
- Navigate to the Payment Information sub-tab under the Personal Data tab.
- Here the Account Number is displayed correctly.
The issue is caused due to some inconsistency.
Resolution
Perform a dummy change by deleting the Bank Account number of the respective Employee. Save the changes and maintain the Account Number again.
Keywords
Bank Account Number, Truncated, Outgoing File, Employee. , KBA , SRD-FIN-MOP , Payment Management , Problem
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public