Symptom
Service confirmation line item is not Linked to a reference sales order/item, due to that the sales order status is not completed.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Field Service and Repair - Service Confirmations work center view.
- Select the Service Confirmation ABC. (ABC represents the Service Confirmation ID)
- Edit and click on View All.
- Navigate to Document flow tab and the sales order DEF is linked to this service confirmation. (DEF represents Sales Order ID)
- Now Navigate to Service and Spare Parts tab.
- Under General sub tab the Reference Sales Order/Item is missing.
Cause
While creating service confirmation, the line item was manually changed and due to that the Reference Sales Order/Item is missing and hence, causes the Sales Order status is not get updated on status.
Resolution
To resolve this issue you can create a new service confirmation with 0 quantity and then perform Complete Service Execution to change the status of sales order to Completed.
- Go to Sales Orders - Sales Orders work center view.
- Select the sales order DEF.
- Click on Submit -> Confirm Service Confirmation.
- Modify the Quantity to 0 and click on Release -> With Order Completion.
- The Service Confirmation created with status Not Relevant.
- Go to sales order DEF.
- Click on Submit -> Complete Service Confirmation.
The Sales Order status changes to Completed.
Keywords
service confirmation; reference sales order; status; not updated; not completed; , KBA , SRD-CRM-ORD , Orders & Contracts , Problem
SAP Knowledge Base Article - Public