SAP Knowledge Base Article - Public

3578456 - Service Confirmation Line Item is Not Linked to a Reference Sales Order/Item

Symptom

Service confirmation line item is not Linked to a reference sales order/item, due to that the sales order status is not completed.  

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Field Service and Repair - Service Confirmations work center view.
  2. Select the Service Confirmation ABC. (ABC represents the Service Confirmation ID)
  3. Edit and click on View All.
  4. Navigate to Document flow tab and the sales order DEF is linked to this service confirmation. (DEF represents Sales Order ID)
  5. Now Navigate to Service and Spare Parts tab.
  6. Under General sub tab the Reference Sales Order/Item is missing.

Cause

While creating service confirmation, the line item was manually changed and due to that the Reference Sales Order/Item is missing and hence, causes the Sales Order status is not get updated on status.

Resolution

To resolve this issue you can create a new service confirmation with 0 quantity and then perform Complete Service Execution to change the status of sales order to Completed. 

  1. Go to Sales Orders - Sales Orders work center view.
  2. Select the sales order DEF.
  3. Click on Submit -> Confirm Service Confirmation.
  4. Modify the Quantity to 0 and click on Release -> With Order Completion.
  5. The Service Confirmation created with status Not Relevant.
  6. Go to sales order DEF.
  7. Click on Submit -> Complete Service Confirmation.

The Sales Order status changes to Completed.  

Keywords

service confirmation; reference sales order; status; not updated; not completed; , KBA , SRD-CRM-ORD , Orders & Contracts , Problem

Product

SAP Business ByDesign all versions