Symptom
In external Career Site, candidate cannot save a draft of job application he's applying to because Save button is missing.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Login to Career Site
- Search and then apply to a job posting
- Notice that Save button is not available
Cause
The job requisition has Quick Apply switched on.
Resolution
Product Managers confirmed that this is behaving as expected, that is, Save button is not available on requisitions with Quick Apply switched on.
The idea of Quick Apply is to allow candidates (with no profile created yet) to easily apply on a job and create a profile at the same time by completing a short application form. There will be no Save button for the candidate to save a draft of application and complete it later on because they have no profile created yet in the first place.
In scenarios when logged in candidate (with existing profile) happen to apply on Quick Apply-enabled requisition, the Save button is also not available. Nonetheless, it is a best practice to include minimum fields on Quick Apply requisitions so that purpose, that is to quickly apply, will not be defeated. With that in mind, it is likely that applicants can complete the form in one go.
You may raise this as an enhancement idea through Customer Influence. Kindly see the KBA 2090228 - How to Submit Ideas for SAP SuccessFactors Products detailing how this process works.
Quick Apply is enabled in the requisition:
Quick Apply is disabled in the requisition:
See Also
2090228 - How to Submit Ideas for SAP SuccessFactors Products
Keywords
Save Button Missing Draft Application Quick Apply , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem