SAP Knowledge Base Article - Public

3578806 - Cannot deactivate application in IAM App - SAP S/4HANA Cloud Public Edition

Symptom

In the app "Maintain Business Roles", the IAM app cannot be deactivated in the role.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. In the app "Maintain Business Roles", access the business role.
  2. In the tab "IAM Apps", select the IAM app to deactivate in the role.
  3. The "Deactivate" button greyed out.

Cause

The app exists in multiple business catalogs which include the catalog that does not support IAM app.

And the both kinds of the catalogs (support IAM app/does not support IAM app) are assigned to the business role at the same time.

Therefore, it is not possible to deactivate IAM apps due to this IAM App Deactivation Limitations in Dependent Business Catalogs.

Resolution

It can be found about if the business catalog supports IAM app in the app "Business Catalog".

To solve the issue, please remove the business catalog (contains the app) which does not support IAM app.

 

See Also

Effects of Using IAM Apps of the App Authorization Variant Type | SAP Help Portal

Keywords

Deactivate, IAM app, Business role, business catalog, App Authorization Variant , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition 2502