Symptom
Work Agreement details for an employee are showing status 'Inactive'.
Environment
SAP S/4HANA Cloud Public Edition.
Reproducing the Issue
- Go to Manage Workforce app.
- Enter 'Worker ID'.
- Click on Work Agreement.
- Go to the details section and status is set to 'Inactive'.
Cause
- The Start Date of the Work Agreement details is set to a future date.
- The Work Agreement End Date is set before the Start Date of the Work Agreement Details.
Resolution
If the Work Agreement End Date is set to a later date than the relevant Work Agreement Details Start Date please go to point 5.
- If the Work Agreement End Date is set before the Start Date of the Work Agreement Details, the relevant Work Agreement Details must be deleted.
- The Work Agreement End Date can then be edited to a future date (one that is later than the Work Agreement Detail Start Date) and saved.
- Once the Work Agreement End Date has been updated, a new Work Agreement Detail can be created with a valid Start Date.
- The Work Agreement Detail Status will now show Active.
- If the Work Agreement End Date is set to a later date than the relevant Work Agreement Details Start Date, the Work Agreement Detail can be edited directly.
- Click the relevant Work Agreement Details.
- Click the 'Correct Start Date' button in the top right corner.
- Specify a Start Date (this Start Date must be a date in the past).
- Click 'Correct Start Date'.
- Work Agreement Details has now been updated and the status has been changed to Active.
“ Above solution is explained with respect to the data source Mange workforce(W), if any other integration channels are being used, these steps need to be executed from the source system”.
See Also
Keywords
Inactive, Work Agreement, Employee, Manage Workforce App, S/4HANA Cloud Public Edition, Workforce Domain Integration, Future Start Date, End Date, Data Source, W, Work Agreement Details Status. , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem