Symptom
For Legal Entity Transfer candidate from Recruiting, after selecting Rehire on New Employment, the process stuck with a BPE process task.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Initiate Legal Entity Transfer > select Rehire on New Employment in Employment Profile Selection
- No process task is triggered
- Go to Manage Data > search "Process Trigger + (applicationId)" > get the onboarding process id (Process Initiation ID)
- Go to BPE: Monitor Processes > filter with processInitiationId=xxxx in "Variable" field > see a job id under the "Onboarding2LegalEntityTransferWorkflow" record
- Go to BPE: Manage Process Tasks > search above job id > click on Restart Task > see error message with timestamp
Cause
There is no business email address on this terminated user's record.
It's necessary to ensure that the business email address of the rehire is specified before initiating onboarding for Legal Entity Transfer.
Guide for reference: Initiating Legal Entity Transfer from SAP SuccessFactors Recruiting | SAP Help Portal
- (For SAP Support only) Backend log: Entity:(emailInfo) invalid emailAddress:(xxx) for userSysId: xxx
(see internal memo for more details)
Resolution
- Add a business email address to the terminated user's record
- Go to BPE: Manage Process Tasks
- Search with job id
- Click on Restart Task
See Also
Keywords
SAP SuccessFactors, Onboarding, Rehire, New Employment, Legal Entity Transfer, Business Email Address, Terminated User, Profile Selection, BPE, Manage Process Tasks , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem