Symptom
- The hire/start date for a new hire was changed via Hire/Start Date Correction tool via Manage Data to, which needs to be updated as well in I9 Section 2
- The updated hire/start date is not reflecting in I9 Section 2
- The new hire is already active and an internal user in EC
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Proxy as the responsible user to complete I-9 Section 2
- See that the Hire/Start Data is still not changed despite the hire/start date has been changed via Hire/Start Date Correction tool and as validated that the new hire/start date is reflecting in EC too
Cause
I-9 was generated during onboarding process but the hire/start date was changed via Hire/Start Date Correction Tool when the user is Hired already
Resolution
Triggering Correct Form I-9 will result in error when accessing/completing it.
Since the new hire is already Hired/Internal user and the I-9 was initiated during the time of onboarding, changes done to the hire/start date after the new hire is hired may not capture from the I-9 forms. Please follow workaround below:
- Go to Manage Data
- On the first drop down - Process
- On the second drop down - best to use the user ID
- Change the Target Date field
- On the first drop down - Compliance Process
- On the second drop down - use the compliance process ID from the Process object (toComplianceProcess section) where Task Type is Complete Form I-9 Section 1
- change the Start Date field
- On the first drop down -I-9 User Data
- On the second drop down - use the user ID again
- Change the hireDate field
See Also
2934829 - How to Change New Hire Start Date in Onboarding - Onboarding
Keywords
obx, I-9 section 2 start hire date, change hire date I-9 section 2 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem