Symptom
In the standard data source "Inbound Delivery Notification Item for All Orders" (SCMIDNB02), filter a customer return delivery notification which follows an Over-the-Counter Sale outbound delivery, Outbound Delivery ID displays as # in the result.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to work center Inbound Logistics, access view Inbound Delivery Notifications.
- Search for Inbound Delivery Notification IDN_1 and select Edit.
- Select the Line Items tab and select any line item, in the below the Outbound Delivery ID has value.
- Go to work center Business Analytics, access view Design Data Sources.
- Search for the data source "Inbound Delivery Notification Item for All Orders" (SCMIDNB02) and select Preview.
- Under Selection, maintain Delivery Notification ID IDN_1 for filter and click Apply.
- In the result, characteristic Outbound Delivery ID displays as # for all line items.
*IDN_1 represents inbound delivery notification ID
Cause
This is a current limitation. Since in Over-the-Counter Sale (OTCS) process there is no sales order, outbound delivery got created from customer invoice request. Thus, in data source SCMIDNB02 for OTCS return, Outbound Delivery ID shows as #.
Resolution
Currently, there is no dedicated data source for OTCS returns. However, after inbound delivery created in OTCS return scenario, related outbound delivery ID can be retrieved through searching for corresponding inbound delivery ID in data source SCMCIDB01.
See Also
Keywords
Over-the-Counter Sale, SCMIDNB02, Outbound Delivery ID, Return , KBA , AP-IDP , Inbound Delivery Processing , Problem
SAP Knowledge Base Article - Public