Symptom
When a phone call is converted to a ticket, clicking on the Contact hyperlink in the Interactions facet opens an empty Account page.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Convert a phone call to a ticket in the SAP Cloud for Customer.
- Go to the Interaction tab of the created ticket.
- Click on the Contact hyperlink.
- Observe that it opens an empty Account page.
Cause
In C4C, the MessageFromParty field is not populated with sender details when a phone call activity is created.
This is because phone calls do not always have a defined "sender" in the same way as other communication types like emails, chats, and messages.
As a result, the sender details appear as empty in the list view specifically for phone calls.
Resolution
To access the contact details when viewing a phone call activity, you can adjust the Default View settings.
This adjustment will allow users to access the contact details when viewing a phone call activity.
Steps:
Navigate to Administration > General Settings > Service and Social > Ticket Configuration > Default View > set as Grid View.
See Also
Keywords
Service Tickets, Contact Hyperlink, Interaction tab, Overview tab, Grid View, phone call activity, empty Account , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To