SAP Knowledge Base Article - Public

3580060 - Contact Hyperlink under Ticket Interaction opens an empty Account

Symptom

When a phone call is converted to a ticket, clicking on the Contact hyperlink in the Interactions facet opens an empty Account page.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Convert a phone call to a ticket in the SAP Cloud for Customer.
  2. Go to the Interaction tab of the created ticket.
  3. Click on the Contact hyperlink.
  4. Observe that it opens an empty Account page.

Cause

In C4C, the MessageFromParty field is not populated with sender details when a phone call activity is created. 

This is because phone calls do not always have a defined "sender" in the same way as other communication types like emails, chats, and messages.

As a result, the sender details appear as empty in the list view specifically for phone calls. 

Resolution

    To access the contact details when viewing a phone call activity, you can adjust the Default View settings.

    This adjustment will allow users to access the contact details when viewing a phone call activity.

    Steps:

    Navigate to Administration > General Settings > Service and Social > Ticket Configuration > Default View > set as Grid View.

    See Also

    Keywords

    Service Tickets, Contact Hyperlink, Interaction tab, Overview tab, Grid View, phone call activity, empty Account  , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To

    Product

    SAP Cloud for Customer core applications all versions