SAP Knowledge Base Article - Public

3580349 - Error Code: 23 - Incorrect Configuration of OData API Call for Updating External Inactive Users

Symptom

  • An error occurs when attempting to update External Inactive users via an OData API call.
  • The error message displayed is: "Error Code: 23 - An error has occurred, please contact the system administrator."

Environment

  • SAP SuccessFactors HCM Suite
    • ODATA API 

Reproducing the Issue

  1. Open Postman and build the following query:
  2. API url: https:///odata/v2/ExternalUser/upsert
  3. Payload:

    {
    "__metadata": 
    "uri": "ExternalUser('****')",

    "type": "SFOData.ExternalUser"

    },

    "userId": "****",

    "status": "e",

    "userName": "test1@test.com"

    }

  4. Run the query and observe the error: "Error Code: 23 - An error has occurred, please contact the system administrator."

Cause

The query was configured incorrectly. Error Code: 23 occurs if the Product Name (productName) is not passed or is passed incorrectly (invalid productName).

Resolution

  1. Ensure that the Product Name (productName) is included in the payload and its valid (ONB,LMS etc)
  2. The payload should contain the following mandatory fields: userId, status, and productName.

See Also

ExternalLearner Error Code Definition | SAP Help Portal

Keywords

OData API, External Inactive Users, Error Code: 23, Update, Payload, productName, userId, status, SAP SuccessFactors. , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors Onboarding all versions