Symptom
- An error occurs when attempting to update External Inactive users via an OData API call.
- The error message displayed is: "Error Code: 23 - An error has occurred, please contact the system administrator."
Environment
- SAP SuccessFactors HCM Suite
- ODATA API
Reproducing the Issue
- Open Postman and build the following query:
- API url: https:///odata/v2/ExternalUser/upsert
- Payload:
{
"__metadata":
"uri": "ExternalUser('****')","type": "SFOData.ExternalUser"
},
"userId": "****",
"status": "e",
"userName": "test1@test.com"
}
- Run the query and observe the error: "Error Code: 23 - An error has occurred, please contact the system administrator."
Cause
The query was configured incorrectly. Error Code: 23 occurs if the Product Name (productName) is not passed or is passed incorrectly (invalid productName).
Resolution
- Ensure that the Product Name (productName) is included in the payload and its valid (ONB,LMS etc)
- The payload should contain the following mandatory fields: userId, status, and productName.
See Also
Keywords
OData API, External Inactive Users, Error Code: 23, Update, Payload, productName, userId, status, SAP SuccessFactors. , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem
Product
SAP SuccessFactors Onboarding all versions