Symptom
- Onboarding was initiated from job requisition but the candidate is not appearing in the onboarding dashboard.
- Onboarding2Workflow entered exception message in BPE Monitor
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Initiate onboarding from recruiting.
- The candidate does not show up in the onboarding dashboard.
- In BPE Monitor when filtered with processInitiationId=EnterProcessTriggerIdHere
- Could see Onboarding2Workflow entered exception message
- Please contact support with exception message error id to check backend logs for more information on cause
Cause
The issue was caused by a username that already exists in the system.
The status is: -12 with the index 0
Resolution
First: Identify the existing user with the same username in the system:
- Search in Data Inspector > Table_USERS_SYSINFO > username Equals OR Search in Data Inspector > Table_USER_ACCOUNT > Username equals to the email address.
- You may have to change the username to search with lowercase or uppercase to find the matching username.
- Example Test@test.com was sent from recruiting for new candidate and test@test.com was username which exists in system.
- If you were able to identify an existing entry with User_Account, then copy the Person ID External Value.
- Data Inspector > Table_USERS_SYSINFO > Select User Sys ID > Equals to the copied value.
- In the "Valid" field check that user is active user "t".
Correcting the issue:
- We can either update primary email address on Recruiting side (check last observation) or we can update username of this existing employee in "Manage Login Accounts".
- If changing the username for the existing user is the best approach, after done, restart the error from Manage Process Tasks.
- If changing username for existing user is not possible, as existing user is a valid user, then you will need to add new candidate in recruiting again with email that does not already exist in the system > Add to job req again and initiate onboarding again.
- Updating the email for the new candidate in UI will not work, as onboarding always uses primary email for username and primary email cannot be updated once created, therefore if same candidate must be proceeded, customer will have to raise a script request following KBA guidance: 3423305.
See Also
Keywords
Onboarding, Candidate, Dashboard, SAP SuccessFactors, Username, Error, Application Error, Manage Process Tasks. "Load external user failed. The status is: -12 with the index 0 ", -12, email, findUserById , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public