SAP Knowledge Base Article - Public

3581469 - Error Response in SuccessFactors App on Microsoft Teams Due to Unconfigured Quick Actions

Symptom

An error message "Unable to load data. Please try again" is displayed when testing commands in the Microsoft Teams integrated with SAP SuccessFactors.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Type "help" command in MS Team's SuccessFactors app.
  2. The error message "Unable to load data. Please try again" is displayed.

Cause

The issue arises when no Quick Action is configured via the SAP SuccessFactors Quick Actions in Microsoft Teams. As a result, the system doesn't find any quick actions from the database side and returns the error message "Unable to load data. Please try again".

Resolution

Administrator should enable one or more SuccessFactors Quick Actions in the SAP SuccessFactors instance via SAP SuccessFactors Quick Actions in Microsoft Teams. Once configured, users will see the main menu card in the Work Tech Teams Bot when entering help-related commands, instead of the error message. 

See Also

Refer to the Guide for configuring Quick Actions in SAP SuccessFactors: [SAP SuccessFactors Quick Actions in Microsoft Teams]

Keywords

Error, SuccessFactors, MS Teams, Unable to load data, Quick Actions, Work Tech, Configuration, Guide, SAP SuccessFactors Platform, Development, Extension Center. , KBA , LOD-SF-EAS-WRK , Collaboration and Work Tech , Problem

Product

SAP SuccessFactors HCM Suite all versions