SAP Knowledge Base Article - Public

3581552 - Cannot Edit Route Group Visit Plan After Activation in SAP Sales Cloud

Symptom

An error occurs if an account already exists in an active Route Group and the same account is added to the copied Route Group.

Environment

SAP Sales Cloud for Customer

Reproducing the Issue

  1. Navigate to the Dynamic Visit Planning work center.
  2. Open the Route Groups work center view.
  3. Open a Route Group which is in IN PREPARATION status.
  4. Change the status to ACTIVE.
  5. Copy Route group and Save
  6. Error Occur: Visit plan for account \{0\} already exists in active route group \{1\}

Cause

If an account already exists in an active Route Group and the same account is added to the copied Route Group, an error will occur "Visit plan for account \{0\} already exists in active route group \{1\}". This is expected behavior. 

Resolution

  1. You can copy a Route Group that is in the status of "In Preparation" or "Obsolete." In this case, you can add or remove accounts from the copied Route Group.
  2. Add or remove the required accounts in the copied Route Group.
  3. This approach allows to proceed without the limitations imposed by the original Route Group’s Visit List generation.

See Also

KBA 3423110 - Cannot edit Route Group Visit Plan after activation

Keywords

SAP Sales Cloud, Route Group, Visit Plan, Edit Option, Disabled, Activation, Visit List Generation, Dynamic Visit Planning. , KBA , LOD-CRM-DVP , SAP Sales Cloud, dynamic visit planning add-on , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions