SAP Knowledge Base Article - Public

3581656 - Delay in the Trigger of Workflow for Credit Memo Requests in SAP S/4HANA Cloud Public Edition

Symptom

  • A delay is observed between the creation of credit memo requests and the triggering of a workflow created for scenario WS02000029.
  • The document becomes eligible for workflow several hours after its creation.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The issue is caused by the conversion of the sales document type key according to different system logon languages. For example, "DA" is the French version of "CR".

Resolution

  1. Go to the "Manage Sales Document Workflows" app and copy a new workflow for credit memo request from the current active workflow.
  2. Maintain the start condition as credit memo request type equaling to "DA" or "CR". 
  3. Activate the new workflow and deactivate the original workflow.
  4. When the system language is French, the workflow can be triggered immediately.

See Also

Keywords

SAP S/4HANA Cloud Public Edition, Credit Memo Request, Workflow, Delay, WS02000029, Conversion, Sales document type, Key, System logon language, DA, CR , KBA , SD-SLS-CMR-2CL , Credit Memo Request and Debit Memo Request (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions