Symptom
With updates to the SuccessFactors Mobile Platform in the May 2025 release, existing mobile app users who have already activated the app may lose their enablement state and be required to re-activate. When this happens, Learning data previously saved to the device is no longer persisted, so any progress on downloaded learning items that has not been synced with LMS will be lost. Additionally, at the time the app is deactivated, any content files downloaded for offline use will be removed from the device.
Environment
- SAP SuccessFactors Learning Management System
- SuccessFactors Mobile Apps (Android and iOS, v14.0 and higher)
Cause
In parallel with the May, 2025 iOS and Android app updates, our Mobile Platform services have been updated to improve the usability and security of the user authentication features. After this change takes place, users may need to re-activate the app at the start of their next session.
Resolution
- If possible, users of the offline download feature should perform a sync prior to the 1H 2025 app store updates, which are scheduled for release on/shortly following May 19th. (pending Apple’s review) To perform a sync, users only need to launch the app and navigate to Learning on their device while it’s connected to a wifi or cellular network. The sync process will take place in the background automatically, and the user will see a success message after a few seconds.
- After re-activating the app, users may also need to re-download any offline learning items which they’d still like to complete offline later.
Keywords
Android, iOS, Successfactors, Learning, Mobile, App, application, iPad, Phone, Tablet , KBA , LOD-SF-LMS-MOB , Mobile Application Issues Only , Known Error