SAP Knowledge Base Article - Public

3582906 - Authentication Method for Standard API Calls in SAP S/4HANA Cloud

Symptom

  • Standard API calls are performed using communication users as an authentication method in SAP S/4HANA Cloud.
  • This method causes difficulties in establishing traceability of the business users who execute these calls.

Environment

SAP S/4HANA Cloud Public Edition > Extensibility & Integration Tools > Key User Extensibility Tools > Custom Communication Scenarios

Reproducing the Issue

  1. Perform calls to standard SAP APIs using communication users as an authentication method.

Cause

The scenario of performing standard API calls providing business users as authentication method instead of communication users is not supported/recommended.

Resolution

  1. It is not possible to call an inbound service from the own system (as in developer extensibility and class/behavior definition).
  2. Alternatives in developer extensibility such as data definition, proxy model, etc, should be used, therefore, the communication user is out of the question, because there is no communication arrangement.
  3. If an inbound service from another system is to be consumed, OAuth can be configured if the API supports it.

See Also

If you want to consume an inbound service from another system, you can configure OAuth if the API supports it.

https://help.sap.com/docs/SAP_S4HANA_CLOUD/0f69f8fb28ac4bf48d2b57b9637e81fa/1e60f14bdc224c2c975c8fa8bcfd7f3f.html

Keywords

SAP S/4HANA Cloud, Standard API calls, authentication method, communication users, business users, traceability, OAuth, inbound service, developer extensibility, data definition, proxy model. , KBA , BC-SRV-APS-COM , Maintain Communication System and Arrangement , Problem

Product

SAP S/4HANA Cloud Public Edition all versions