SAP Knowledge Base Article - Public

3583355 - Unable to load I9 forms in the Complete I-9 section 1 step - Onboarding

Symptom

  • The I9 forms are not loading during the Complete I-9 section 1 step, other US State Compliance forms working fine.
  • Compliance forms for the US country, including the I-9 form template, are not available within PFS.
  • Other countries forms, such as Australia and UK, are present in PFS even though they have not been enabled.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log in to the Onboarding Portal as the candidate.
  2. Navigate to the Complete I-9 section 1 step.
  3. Attempt to load the I-9 section 1 and it will not load.

Cause

The "area-code" was not enabled, which is a mandatory field for the I9 forms.

Resolution

  1. Go to Manage Business Configuration > phoneInfo.
  2. Enable "Area Code (area-code)".
  3. Save the changes.
  4. Validate if the forms are now able to load as expected.

Keywords

I9, I9 section 1, keep loading, form, loading, compliance, PFS, area-code, mandatory, field. , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem

Product

SAP SuccessFactors Onboarding all versions