Symptom
You are trying to record times for a specific service activity, however the required service is not listed when opening the value help for the Activity field.
Environment
SAP Business ByDesign
Reproducing the Issue
- Open the Home work center.
- Enter the Self-Services overview view.
- Click on the Edit Time Sheet link.
- Click on the Add Row button.
- Open the value help for the Activity field.
Here, the expected service is not listed.
Cause
The services created in the system will only be listed in the Activity value help when the employee selects a project task in the Task field. This will enable the user to record times of service execution.
The value help for the Activity field will list only services which have a unit of measure based on time (for example, hours, days, weeks, etc.). The time unit of measure can be defined either as the base UoM of the service, or included in a quantity conversion. Once the time unit of measure is set, the service should appear in the value help list.
Resolution
The system works as expected.
In order to check the unit of measure for the required service, please follow the steps below:
- Open the Product Portfolio work center.
- Enter the By Services view.
- Search for the required service.
- Click on the Edit button.
- Click on the View All button.
Here, a time unit of measure needs to be defined either in the Base UoM field, or be one of the units listed in the Quantity Conversions table.
Keywords
ESS, Book, TLM , KBA , SRD-HR-TLM , Time and Labour Management , Problem