Symptom
- An error occurs when attempting to edit a G/L Account in the Manage G/L Account Master Data application.
- The error message displayed is "Another user is currently locking Account &1 in Chart of Accounts YCOA".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Log into the Manage G/L Account Master Data application.
- Filter by YCOA chart of accounts.
- Filter by the account number * and try to edit it.
Cause
The issue arises due to a lock in place whenever there is an open draft in the successor app 'Manage Operating G/L Accounts'. This is to prevent the same account from being changed simultaneously in both apps.
Resolution
- Access the 'Manage Operating G/L Accounts' application.
- Click on Edit to access the existing draft.
- Discard the existing draft. This action should resolve the locked issue.
Keywords
G/L Account, Edit, Locked, Chart of Accounts, YCOA, Manage G/L Account Master Data, Error, SAP Cloud Public, DEV Customizing, Manage Operating G/L Accounts, Draft. , KBA , FI-FIO-GL-2CL , Fiori UI for General Ledger Accounting (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions