SAP Knowledge Base Article - Public

3584203 - Custom Fields are Not Visible in the New Application Workbench - Recruiting Management

Symptom

Newly added custom fields are visible in Legacy Workbench > More Information but not in the New Application Workbench.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  • Scenario 1
  1. Configure a custom field in BOTH the candidate profile and application template
  2. Recruiters can see the fields in the Legacy Workbench > More Information Section
  3. Navigate to the new workbench and the custom field is not visible
  • Scenario 2:
  1. Configure a custom field in candidate profile ONLY
  2. Recruiters can see the fields in the Legacy Workbench > More Information Section
  3. Navigate to the new workbench, the field is visible in the New Application Workbench under "Profile Information"

Cause

  • Cause 1: There is no permission for the recruiters to view/edit the fields in the application. The More Information portlet displays all fields configured in the candidate profile template.
  • Cause 2: This is expected behavior with the legacy and latest workbench if the field is only configured in the candidate profile template. 

Resolution

  • Solution 1:

When you configure a custom field in both the candidate profile and application templates:

  • In the Legacy Candidate Workbench, the field displays under BOTH Application Information and More Information portlets (honoring respective candidate profile and application template read and edit permissions).
  • In the Latest Candidate Workbench, the field displays ONLY in Application Information (honoring only application template read and edit permissions).

For the field to be visible in the Latest Workbench:

  • Grant users read and/or write permissions on the custom field so it will be visible to users in the Application Information portlet.
  • Note: For multistage application enabled, field permissions are configured in the requisition template. see KBA for details: 2644504 - How to update permissions for Job Application fields via Manage Templates Feature 

  • Solution 2:

This is expected behavior. When you configure a custom field only in the candidate profile template:

  • In the Legacy Candidate Workbench, the field displays only in More Information portlet
  • In the Latest Candidate Workbench, the field displays only in Profile Information section

See Also

2644504 - How to update permissions for Job Application fields via Manage Templates Feature - Recruiting Management

Keywords

custom field, field not visible, field permission, legacy workbench, latest workbench , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions