Symptom
- The user is unable to complete the I9 Section 2.
- The error message "Unable to save the changes" is displayed.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Provide the reason for the delay.
- Complete the I-9 Section 2 form.
- Click Submit.
- An error message stating "Unable to save the changes" will appear.
Cause
- The issue arises because the reason for delay field only accepts a maximum of 255 characters.
- The character count has exceeded the limit, preventing the changes from being saved.
Resolution
- Identify that the character count for the reason for delay field has exceeded the limit.
- To identify the number of characters when encountering the error, please follow the steps below:
- While in I-9 Section 2, right-click your mouse and select "Inspect."
- Go to the "Network" tab.
- Provide the reason for the delay.
- Complete the I-9 Section 2 form, and once the error is replicated, click on the batch file. You should see something like this:
Sample Network Logs:
{
"error" : {
"code" : "COE_PROPERTY_EXCEED_MAX_LENGTH", "message" : {
"lang" : "en-US", "value" : "ChangeSet index 1 - Maximum length limit exceeded for field reasonForDelay: actual length: 280; maximum length: 255."
}
}
}
2. Reduce the character count to 255 or fewer for it to be saved successfully.
See Also
Keywords
I9, I9 Section 2, Unable to save changes, character limit exceeded, reason for delay, Compliance, OBX, Onboarding , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
Product
SAP SuccessFactors Onboarding all versions