Symptom
The Service Order ABC status has changed from "Completed" to "In Process", even though the invoicing process is finished. (ABC represents the Service Order ID).
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Service Orders workcenter.
- Go to the Service Order Processing view.
- Search for the ID ABC.
- Click on Edit.
- Click on View All.
- Go to the Services and Spare Parts tab.
The Service Order status is In Process even though all of the items were completed and invoiced.
Cause
The Service Order status changed to In Process because the Purchase Order which was linked to it was deleted.
Once the Invoicing process is in place for a Service Order, previous documents such as the Purchase Order should not be canceled/deleted, otherwise this action will lead to an inconsistency since the Order will have the status 'In Process' even after the Customer Invoice release.
Resolution
This is the expected system behavior.
In case it is desired to Complete the Service Order after the Purchase Order was deleted, it is possible to complete the order manually by clicking on Submit -> Complete Service Execution button on the Service Order document. Then, the status will be changed to Completed.
In order to complete the document with a new Purchase Order, the PO must be created again from the Purchase Request. Then, after confirming the newly ordered quantity through the Service Confirmation and releasing the follow up Customer Invoice, the document will be Completed.
Keywords
Service order, purchase order, status, change, completed, in process, finished, canceled, deleted, execution, byd. , KBA , AP-SLO-SO , Sales Order , How To