Symptom
When attempting to create a home page tile and clicking save, an error message appears: "We couldn’t save changes to the custom card. Check the card configuration or contact your administrator."
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors HCM Core
Reproducing the Issue
- Navigate to Manage Home Page Tiles.
- Go to Organization Updates.
- Add a tile and enter the mandatory information.
- Complete all the information in detail.
- Click Save. The error message will then be displayed.
Cause
This issue arises due to a mismatch between the system's default locale and the language pack configured in the SF instance.
For example, if the customer has enabled a language pack 'en_UK' while their system's default locale is 'en_US', and it will result in a 'BAD_REQUEST' at the network level, causing this error.
Resolution
Please ensure that the language pack aligns with the system's locale. If it's not, please enable the corresponding language pack in the SuccessFactors instance according to this Help Portal - Enabling Languages to Use in the System.
See Also
Keywords
Error Message, Home Page Tile, Custom Card, Card Configuration, Save Changes, Tile Creation, Manage Home Page Tiles, Organization Updates, Error Displayed , KBA , LOD-SF-PLT-TIL , Custom Tile/Card Issues , Problem