SAP Knowledge Base Article - Public

3585048 - Company Code is not visible in Manage Workforce

Symptom

In Manage Workforce Company Code is not visible under Work Agreement tab.

Environment

SAP S/4HANA Cloud Public Edition

Cause

This issue occurs when there is a mismatch in validity between the Work Agreement and Business Partner. 

This issue shouldn't happen anymore, however the existing records has to be fixed.

Resolution

If the data source is Manage Workforce or Import Function:

  • If the affected worker only has one work agreement, then this issue can be solved by sending a dummy update with the worker and work agreement data through the import function.
    Once the import is successful, the data should be fixed, and the Company Code will be visible in Manage Workforce. The recommended template is the Worker and Work Agreement.
    When updating a worker via the import function, please ensure the template is filled based on existing data. Leaving columns blank will delete any data currently present in Manage Workforce.
    If a worker's data is being reimported, any associated payment information or private address must also be reimported. Otherwise, this could lead to data inconsistencies. 
  • If the worker has more than one work agreement then the import function cannot be used. In this case, the inconsistent work agreement has to be blocked, and a new one must be created.
    • In this case open a case for component CA-WFD-INT.

If the data source is SOAP, MDI or JB1:

If the Data Source is not Manage Workforce or Import Function, then the root cause should be identified first. Use the following parameters in Message Monitoring Overview app: /WFD, WFD_WORKER, 1

First the existing error message has to be fixed, once it's fixed send a dummy update to fix the data.

Keywords

Company Code, Work Assignment, details , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-GTF-BUM , Business User Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions