SAP Knowledge Base Article - Public

3585240 - Mexico Electronic Payment Document: Clearing Item Overview Tab Shows 'No records found' Message

Symptom

In Mexico Electronic Payment Document, the Clearing Item Overview tab shows 'No records found' message for a Clearing ID tied to invoices of a particular Customer Account ABC (ABC means the Customer Account ID).

Environment

SAP Business ByDesign 

Reproducing the Issue

  1. Go to the Receivables work center.
  2. Go to the Electronic Payment Documents view.
  3. Find and open the respective Electronic Payment Document, which was created from an Electronic Payment Run DEF (DEF means the Electronic Payment Run ID).
  4. Click Document List tab.
  5. Select the row of any customer invoice document belonging to customer account ABC and click Clearing Details tab.
  6. Select the row of Clearing ID AAA (AAA means the Clearing ID).
  7. Below that, select Clearing Item Overview tab: notice that system show 'No records found'.

The expectation was to see Clearing Item details, such as Payment Assignment Value, Document ID, Document Type, Open Amount, etc.

Cause

The business partner account ABC has been created as a mixed account type in the system, meaning it is both customer and supplier.

This can be checked as follows:

  1. Go to the Receivables work center.
  2. Go to the Customer Accounts view.
  3. Search for account ABC and click over it.
  4. Open General tab.
  5. Notice that under Total of Statistical Items there's a hyperlink Show Supplier Account. This make evident that account ABC is both customer and supplier in the system.

In Electronic Payment Run DEF, out of all accounts fetched, only account ABC is a mixed account type, while all other provided accounts are customer accounts only.

According to the existing backend logic, there is a validation for mixed account types that clears the clearing item details data, which results in the Clearing Item Overview data being omitted from the Electronic Payment Document, when the run is executed containing accounts of both mixed account type and customer account type.

Resolution

To overcome this issue, there are two possibilities:

  1. Execute the Electronic Payment Run excluding the account ABC (and processing the other customer accounts). Afterward, execute a separate run for account ABC only. This will ensure the e-payment documents are created with the Clearing Item Overview data.
  2. Alternatively, if account ABC has been defined as a mixed account type by mistake (for example, during data migration) and there's no transactional data created for supplier ABC, a case can be reported to SAP Support asking to change account ABC from mixed account type to customer account type from backend system. 

Remark: for clearings created before the change of account ABC, the issue will remain. These clearings must be reset, then the invoices clearing again and the Electronic Payment Run executed again, which will create a new Electronic Payment Document with correct Clearing Item Overview this time.

Keywords

mexico electronic payment document; e-payment document; electronic payment run; clearing item overview; PartyRoleCategoryCode; BO FOPXD_TRPACCT; BO Node: TradeReceivablesPayablesAccount - Root  , KBA , SRD-SRM-GLO , Supplier Relationship Management Globalization , Problem

Product

SAP Business ByDesign all versions