SAP Knowledge Base Article - Public

3585244 - Error Message "Invoice request ABC item XX not possible; reference document missing" When Releasing the Service Confirmation Invoice Request

Symptom

When trying to Release the Service Confirmation Invoice Request ABC, the following error occurs:

"Invoice request ABC item XX not possible; reference document missing" (where ABC represents the Invoice Request ID, and XX, the Item ID).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Customer Invoicing workcenter. 
  2. Go to the Invoice Requests view. 
  3. Search for the ID ABC. 
  4. Select the Service Confirmation Invoice Request (with status To Be Invoiced).
  5. Click on Edit.
  6. Click on Release. 
The error message is displayed on the newly created document.

 

Cause

The line item XX is a 'Service - time and material' product and it is invoiced by the Service Confirmation.

On the Service Order XYZ, the non-billable indicator was marked for this item, which means that it will be excluded from the invoice. However, the indicator is not set to the Service Confirmation ABC because it was unmarked before the Confirmation Release, and that is why the item is still relevant to the Service Confirmation Invoice Request (where XYZ stands for the Service Order ID).

The Invoicing data conflicts between the Service confirmation and the Service Order for the item XX, and hence, the error occurs.

Resolution

In order to prevent this issue from happening, always ensure that the non-billable indicator is set for 'Service - time and material' items on the Service Confirmation, and not on the Service Order (as it is done for Service - fixed price items).

To resolve the issue, Cancel the service confirmation and create it again, marking the Non-billable indicator for the line item XX by performing the following steps:

  1. Navigate to the Service and repair workcenter.
  2. Go to the Service Confirmations view.
  3. Select All Confirmations from the dropdown.
  4. Search for the ID ABC.
  5. Click on Edit.
  6. Click on View All.
  7. Maintain any reason on the Reason For Rejection field.
  8. Click on Save.

Now, the Service Confirmation is Canceled.

  1. Navigate to the Service Orders workcenter.
  2. Go to the Service Order Processing view.
  3. Select All Orders from the dropdown.
  4. Search for the ID XYZ.
  5. Click on Edit.
  6. Click on Submit -> Confirm Service Execution.
  7. A new Service Confirmation will be created. Click on View All.
  8. Go to the Service and Spare Parts tab.
  9. Mark the non-billable indicator.
  10. Release the Service Confirmation.

Now, the line item XX should not be relevant to the invoicing process, erasing the conflict and making the scenario consistent.

See Also

KBA 2880955 - Non-Billable Indicator not Selected in Service Confirmation

Keywords

Invoice Request, Reference document missing, Service Confirmation, Service Order Processing, Non-billable indicator, Error, ByD. , KBA , SRD-CRM-INV , Customer Invoicing , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign all versions