SAP Knowledge Base Article - Public

3585292 - Error "SoapFault:faultstring=MustUnderstand headers" in CPI During BPEM Case ID Confirmation

Symptom

When creating an Utilities Exception in a SAP Cloud for Customer (C4C) ticket, the following error is raised in the SAP Cloud Platform Integration message monitoring for the iflow "BPEM Status Replication":

Inbound processing in endpoint at /Utilities/BPEMStatusReplication failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand".

Environment

  • SAP Cloud for Customer
  • Utilities integration with Cloud for Customer
  • SAP ERP

Cause

Wrong configuration of the ERP SOA logical port.

Resolution

In order to resolve the issue, please perform the following configuration changes in the SAP ERP system:

  1. Run transaction SOAMANAGER.
  2. Select Web Service configuration and search for proxy CO_COD_UTILUTILITIES_BPEM_STAT.
  3. Edit the existing Logical Port.
  4. Go to the Messaging tab and set "RM Protocol" as SAP RM and  "Message ID protocol" as SAP Message ID and save it.

Keywords

SOAMANAGER, /Utilities/BPEMStatusReplication, MustUnderstand, WSA, C4C, SRT_UTIL. , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer core applications 2502