Symptom
Error is thrown when trying to change Forecast Hierarchy in Pipeline Management settings.
Environment
- SAP Sales Cloud Version 2
- SAP Sales Cloud and Service Cloud Version 2
Reproducing the Issue
- Go to User Menu.
- Open Settings.
- Navigate to Pipeline Management and Forecasting.
- Open General Settings.
- In Forecast Hierarchy, change it to Territory Hierarchy.
- Save it.
- Error: "Looks like we’ve encountered an error when attempting to save. Please contact support so we can investigate this further" is thrown.
Cause
The issue is happening because the configuration maintained is to have Target Plan in Forecast Tracker. Since Target Plans only support Sales Units currently, we ensure that all screens are based on Sales Unit Hierarchy. If not, functionality will not work.
Hence, it is not possible to use Forecasting with Territory and Target Plans at the same time currently.
Resolution
In case you would like to use forecasting with Territory, please restrict usage of Target Plan.
Note: You can only change from "Manual" to "Target Plan". You cannot reverse this setting as it could lead to inconsistencies in Target and it would lead to the error mentioned above. In case you would use target plan, please move to Sales Unit Hierarchy and then switch Target to Target Plan.
Keywords
Target Plan , Forecasting , Error , Territory , Sales Unit , Forecast Hierarchy , KBA , CEC-CRM-PMF , Pipeline Management and Forecasting for Sales Cloud , Problem