Symptom
When creating a new Lead, you can see some Sales Organizations in the "My Sales Organizations" query, even though your user is not linked to these Sales Orgs.
Environment
- SAP Sales Cloud Version 2
- SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Login with the affected user.
- Go to Leads view.
- Click "+" to create a new Lead.
- In the creation screen, select Sales Organization field.
- Open the value help and select "My Sales Organizations" query.
- User can see Sales Orgs that are not linked to them.
Cause
This is the correct behavior of the system.
Resolution
When the user select Sales Organization field upon Lead creation, the value help only shows a list of all Org Units with function flag "Sales Organizations".
However, when the user switch the value help query to "My Sales Organizations", the system starts to search for Org Units with function flag "Sales Organization" where the user is directly assigned to and, if not found, it will climb-up the OrgUnit hierarchy until the first Sales Organization is found.
Hence, "My Sales Organizations" returns all that Org Units where the actual logged-in user is aligned in the Org Unit hierarchy model.
Keywords
Sales Org , Query , Value Help , My Sales Organizations , Visible , Assigned , KBA , CEC-CRM-LEA , Lead for SAP Sales/Service Cloud , Problem