Symptom
When trying to add competencies in competency field it is not showing all competencies
Environment
SAP SuccessFactors Career Development Plan
Reproducing the Issue
- Login to instance
- Go to Admin Center > Goals
- Select your Development Plan template
- Click on the competency browser
- Not all competencies showing
Cause
No competency filter configuration on the Career Development Plan xml
Resolution
If there is no configuration for "competency-filter", the source of competencies will be from user's roles and forms. That's why not all competencies will be displayed in the competency picker (not all linked to roles or not all included in the forms).
If user would like to include all competencies in the instance, please configure below filter in the CDP XML.
<competency-filters>
<exclude type="forms"/> <exclude type="roles"/>
<exclude type="skills"/>
<exclude type="questions"/> </competency-filters>
See Also
Keywords
Competency picker Competency browser , KBA , LOD-SF-CDP-ADM , Admin Tools, Permissions, Settings , Problem
Product
SAP SuccessFactors HCM Core 2411
SAP Knowledge Base Article - Public