SAP Knowledge Base Article - Public

3585366 - Not all Competencies showing in Competency browser

Symptom

When trying to add competencies in competency field it is not showing all competencies

Environment

SAP SuccessFactors Career Development Plan

Reproducing the Issue

  1. Login to instance
  2. Go to Admin Center > Goals
  3. Select your Development Plan template
  4. Click on the competency browser
  5. Not all competencies showing

Cause

No competency filter configuration on the Career Development Plan xml

Resolution

If there is no configuration for "competency-filter", the source of competencies will be from user's roles and forms. That's why not all competencies will be displayed in the competency picker (not all linked to roles or not all included in the forms).

If user would like to include all competencies in the instance, please configure below filter in the CDP XML.

<competency-filters>
 <exclude type="forms"/>   <exclude type="roles"/>
 <exclude type="skills"/>
 <exclude type="questions"/> </competency-filters>

See Also

https://help.sap.com/docs/SAP_SUCCESSFACTORS_SUCCESSION_AND_DEVELOPMENT/64ae041fbac7421f9816ca6d762f4612/47500c7df7f74463be3338c1f79e6d3f.html?q=show-competency-browser

Keywords

Competency picker Competency browser , KBA , LOD-SF-CDP-ADM , Admin Tools, Permissions, Settings , Problem

Product

SAP SuccessFactors HCM Core 2411