SAP Knowledge Base Article - Public

3585369 - Business Users Are Locking in C4C After Replicatoin of Employees to C4C

Symptom

A significant number of users are being locked in C4C after replication of employees to C4C.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the General Setting work center view.
  3. Open the Web Service Message Monitoring under System Administration.
  4. Select query All.
  5. Search for employee ID 1234 (where 1234 means a generic Employee ID) and verify the replication was successfully processed.
  6. Go to the Business Users and search for the business user associated to Employee ID 1234;
  7. The business user is locked.

Cause

In the incoming payload, you are passing the field <UserAccountsInactiveIndicator>true</UserAccountsInactiveIndicator> is set to TRUE. 

Resolution

To avoid locking the users, the field <UserAccountsInactiveIndicator>true</UserAccountsInactiveIndicator> should be set as FALSE in the iflow in the middleware.

See Also

KBA 2745954 - Locked User Becomes Unlocked After Replicating an Employee from CRM with USER_ACCTS_INACTIVE_IND Set to True

KBA 2923192 - Users are Getting Unlocked Automatically

Keywords

UserAccountInactiveIndicator, Employee, Employee Replication, User, User Locked, User Unlocked, CRM, C4C, Cloud for Customer, True, False, Business User, Locking, Unlocked, Locked, Employee Replication. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications all versions