Symptom
A significant number of users are being locked in C4C after replication of employees to C4C.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for employee ID 1234 (where 1234 means a generic Employee ID) and verify the replication was successfully processed.
- Go to the Business Users and search for the business user associated to Employee ID 1234;
- The business user is locked.
Cause
In the incoming payload, you are passing the field <UserAccountsInactiveIndicator>true</UserAccountsInactiveIndicator> is set to TRUE.
Resolution
To avoid locking the users, the field <UserAccountsInactiveIndicator>true</UserAccountsInactiveIndicator> should be set as FALSE in the iflow in the middleware.
See Also
Keywords
UserAccountInactiveIndicator, Employee, Employee Replication, User, User Locked, User Unlocked, CRM, C4C, Cloud for Customer, True, False, Business User, Locking, Unlocked, Locked, Employee Replication. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To